You are not connected...
Connection to the site
Theme: 
Language : english

AMD Ryzen: USB problems with 400 / 500 series chipsets, a solution in April

Vignette
Written by Guillaume
Publication date: {{ dayjs(1616346014*1000).local().format("L").toString()}}
This article is an automatic translation

Identified by many users, problems of untimely disconnection of the USB on Ryzen platforms have been recognized by AMD.

For a few months now, the Reddit platform has been posting sorry comments from users of AMD Ryzen configurations based on 500 series chipsets. The poor bastards complain of slow speeds on most of the peripherals connected to USB on the machine and even mention disconnection as painful as sudden. According to the feedback, the problems mainly affect the A520, B550 and X570 chipsets when they are linked to Ryzen 3000 series or Ryzen 5000 series processors. However, some have also mentioned problems with the B450 and X470 chipsets.

A few days ago, AMD sent a response. The first piece of good news is that the company did not deny the users' allegations. Better yet, it even asked for help from the community, which seems to have already provided a lot of information to help AMD. The Ryzen developer quickly came back on Reddit to confirm the problems encountered by its users and to specify that a solution was under development. AMD then took the opportunity to make amends and thank the community for " the help it has given us by providing logs and reports during our investigation of USB connectivity issues.

AMD explains that a patch will be available soon. It will be delivered to AMD suppliers and then deployed through BIOS updates. AMD does not detail the changes made and finally does not give any information about the source / the real cause of the problem. If you are affected by this inconvenience and while waiting for the deployment of the patch scheduled for April, it is still possible to consult a list of tips drawn up by AMD to solve the thing.